aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8c5899093a..b2ab6502e3 100644
--- a/configure.in
+++ b/configure.in
@@ -66,13 +66,23 @@ AM_GNOME_GETTEXT
GNOME_X_CHECKS
+dnl
dnl Purify support
+dnl
AC_ARG_ENABLE(purify,
[ --enable-purify=[no/yes] Enable support for building executables with
Purify.],,enable_purify=no)
AC_PATH_PROG(PURIFY, purify, impure)
+AC_ARG_WITH(purify-options, [ --with-purify-options=OPTIONS Options passed to the purify command line (defaults to PURIFYOPTIONS variable).])
+if test "x$with_purify_options" = "xno"; then
+ with_purify_options="-always-use-cache-dir=yes -cache-dir=/gnome/lib/purify"
+fi
+if test "x$PURIFYOPTIONS" = "x"; then
+ PURIFYOPTIONS=$with_purify_options
+fi
AC_SUBST(PURIFY)
-AM_CONDITIONAL(ENABLE_PURIFY, test "x$enable_purify" = "xyes" -a "x$purify" != "ximpure")
+AM_CONDITIONAL(ENABLE_PURIFY, test "x$enable_purify" = "xyes" -a "x$PURIFY" != "ximpure")
+PURIFY="$PURIFY $PURIFYOPTIONS"
dnl * Time zone stuff
AC_CACHE_CHECK(for timezone variable, ac_cv_var_timezone,