aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4e8f3d822e..31388c41b2 100644
--- a/configure.in
+++ b/configure.in
@@ -416,6 +416,24 @@ AC_SUBST(A11Y_CFLAGS)
AC_SUBST(A11Y_LIBS)
dnl **************************************************
+dnl * XF86 multimedia keys support
+dnl **************************************************
+have_xfree=no
+AC_COMPILE_IFELSE([
+ #include <X11/XF86keysym.h>
+ int main(int argc,char **argv) {
+ return 0;
+ }
+ ],
+ have_xfree=yes
+)
+AC_MSG_CHECKING(for X11 XFree86 headers)
+AC_MSG_RESULT([$have_xfree])
+if test x"$have_xfree" = "xyes" ; then
+ AC_DEFINE(HAVE_XFREE, 1, [defined if you have X11/XF86keysym.h])
+fi
+
+dnl **************************************************
dnl LDAP support.
dnl **************************************************
if test "$os_win32" != yes; then