aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ec503f28b7..02fc6555fb 100644
--- a/configure.in
+++ b/configure.in
@@ -32,8 +32,12 @@ AC_DEFUN(EVO_CHECK_LIB, [
ok=yes
if test "$pkgvers" -lt $cmpminvers; then
ok=no
- elif test -n "$maxvers" -a "$pkgvers" -ge $cmpmaxvers; then
- ok=no
+ elif test -n "$maxvers"; then
+ if test "$pkgvers" -gt $cmpmaxvers; then
+ ok=no
+ elif test "$maxvers" != "$minvers" -a "$cmpmaxvers" -eq "$pkgvers"; then
+ ok=no
+ fi
fi
if test $ok = no; then
case $maxvers in