aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c9f019aa4c..8b7dee9afb 100644
--- a/configure.in
+++ b/configure.in
@@ -340,6 +340,13 @@ dnl ******
dnl XML
dnl ******
GNOME_XML_CHECK
+xmlversion=`xml-config --version | sed 's/^libxml//'`
+xmlmajor=`echo $xmlversion | awk -F. '{print $1;}'`
+xmlminor=`echo $xmlversion | awk -F. '{print $2;}'`
+xmlpatch=`echo $xmlversion | awk -F. '{print $3;}'`
+if test "$xmlmajor" -ne 1 -o "$xmlminor" -ne 8 -o "$xmlpatch" -lt 7; then
+ AC_MSG_ERROR(gnome-xml 1.8.7 (or later, but not 2.0) is required to compile Evolution)
+fi
AC_SUBST(CAPPLET_LIBS)