aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f0e5d704fe..8f3bf12ec1 100644
--- a/configure.in
+++ b/configure.in
@@ -65,7 +65,18 @@ AM_CONDITIONAL(ENABLE_THREADS, $have_pthread)
dnl **************************************************
dnl * Print check
dnl **************************************************
-GNOME_PRINT_CHECK
+AC_MSG_CHECKING(for GnomePrint libraries >= 0.10)
+if gnome-config --libs print > /dev/null 2>&1; then
+ vers=`gnome-config --modversion print | sed -e "s/gnome-print-//" | \
+ awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
+ if test "$vers" -ge 10; then
+ AC_MSG_RESULT(found)
+ else
+ AC_MSG_ERROR(You need at least GNOME print 0.10 for this version of Gnumeric)
+ fi
+else
+ AC_MSG_ERROR(Did not find GnomePrint installed)
+fi
dnl **************************************************
dnl * ORBit support