aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 75ce24caed..d39d3e011e 100644
--- a/configure.in
+++ b/configure.in
@@ -92,16 +92,16 @@ dnl **************************************************
dnl * ldap related stuff.
dnl **************************************************
AC_CHECK_LIB(lber, ber_get_tag, LDAP_LIBS="-llber")
-if test $ac_cv_lib_lber_ber_get_tag = yes; then
+if test x$ac_cv_lib_lber_ber_get_tag = xyes; then
AC_CHECK_LIB(ldap, ldap_open, LDAP_LIBS="-lldap $LDAP_LIBS", ,-llber)
fi
-if test $ac_cv_lib_ldap_ldap_open = yes; then
+if test x$ac_cv_lib_ldap_ldap_open = xyes; then
AC_DEFINE(HAVE_LDAP)
AC_SUBST(LDAP_LIBS)
else
AC_MSG_WARN(no ldap support present)
fi
-AM_CONDITIONAL(ENABLE_LDAP, test $ac_cv_lib_ldap_ldap_open = yes)
+AM_CONDITIONAL(ENABLE_LDAP, test x$ac_cv_lib_ldap_ldap_open = xyes)
dnl **************************************************
dnl * Posix thread support