aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 049d3f93f9..aa9ac8db41 100644
--- a/configure.in
+++ b/configure.in
@@ -61,6 +61,7 @@ AC_PROG_CPP
AC_C_INLINE
AM_PROG_LEX
AC_PROG_YACC
+AC_PROG_AWK
case $YACC in
*yacc*)
AC_MSG_ERROR(You need bison to build Evolution)
@@ -1576,7 +1577,7 @@ if echo ${plugins_enabled} | grep "new-mail-notify" > /dev/null ; then
# Get the version of the DBus API, so we can hack around API changes until the API stabilises:
# multiply by 1000 to convert decimal to integer; so e.g. 0.31 become 310
# since preprocessor values must be integral
- DBUS_VERSION="`$PKG_CONFIG --modversion dbus-1 | awk '{print 1000 * $1}'`"
+ DBUS_VERSION="`$PKG_CONFIG --modversion dbus-1 | $AWK '{print 1000 * $1}'`"
AC_SUBST(DBUS_VERSION)
else
plugins_enabled=`echo $plugins_enabled | sed -e "s/new-mail-notify//g"`