aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index c47eaf2a77..a44167beb7 100644
--- a/configure.in
+++ b/configure.in
@@ -892,16 +892,19 @@ dnl Mono hooks
dnl This should just define mono CFLAGS etc here, it is used later to
dnl turn on the mono plugin or not.
+MONO_CFLAGS=
+MONO_LIBS=
AC_ARG_ENABLE([mono],
AC_HELP_STRING([--enable-mono],
[Add Mono embedded hooks.]),
[enable_mono=$enableval],[enable_mono=no])
-
if test "x${enable_mono}" = "xyes"; then
+ PKG_CHECK_MODULES(MONO, "mono")
AC_DEFINE(ENABLE_MONO,1,[Define if Mono embedding should be enabled])
- mono_package="mono"
MONO_PLUGIN="mono"
fi
+AC_SUBST(MONO_CFLAGS)
+AC_SUBST(MONO_LIBS)
dnl Python hooks
dnl This should just define python CFLAGS etc here, it is used later to
@@ -1494,7 +1497,7 @@ else
E_UTIL_X11_CFLAGS=""
E_UTIL_X11_LIBS=""
fi
-EVO_SET_COMPILE_FLAGS(E_UTIL, libbonoboui-2.0 libglade-2.0 libgnomeui-2.0 libedataserver-$EDS_PACKAGE libedataserverui-$EDS_PACKAGE camel-$EDS_PACKAGE $mozilla_nspr $mono_package, $THREADS_CFLAGS $MANUAL_NSPR_CFLAGS $E_UTIL_X11_CFLAGS, $THREADS_LIBS $MANUAL_NSPR_LIBS $E_UTIL_X11_LIBS)
+EVO_SET_COMPILE_FLAGS(E_UTIL, libbonoboui-2.0 libglade-2.0 libgnomeui-2.0 libedataserver-$EDS_PACKAGE libedataserverui-$EDS_PACKAGE camel-$EDS_PACKAGE $mozilla_nspr $THREADS_CFLAGS $MANUAL_NSPR_CFLAGS $E_UTIL_X11_CFLAGS, $THREADS_LIBS $MANUAL_NSPR_LIBS $E_UTIL_X11_LIBS)
AC_SUBST(E_UTIL_CFLAGS)
AC_SUBST(E_UTIL_LIBS)
@@ -1519,7 +1522,7 @@ dnl --- evolution (shell) flags
NM_SUPPORT_PACKAGES=""
PKG_CHECK_MODULES(NM, dbus-glib-1, NM_SUPPORT="yes", NM_SUPPORT="no")
-AC_CHECK_HEADER(NetworkManager/NetworkManager.h, [nm_header="yes"])
+AC_CHECK_HEADER(NetworkManager/NetworkManager.h, [ nm_header="yes" ] )
if test "x$NM_SUPPORT" = "xyes" -a "x$nm_header" = "xyes"; then
AC_DEFINE(NM_SUPPORT, 1, [network manager available])
NM_SUPPORT_PACKAGES="dbus-1 dbus-glib-1"
@@ -1735,7 +1738,7 @@ plugins_base_always="calendar-file calendar-http calendar-weather itip-formatter
plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN $EXCHANGE_PLUGIN $MONO_PLUGIN "
all_plugins_base="$plugins_base_always sa-junk-plugin bogo-junk-plugin exchange-operations mono"
-plugins_standard_always="bbdb subject-thread save-calendar select-one-source copy-tool mail-to-task mark-calendar-offline audio-inline mailing-list-actions default-mailer import-ics-attachments prefer-plain mail-notification attachment-reminder face backup-restore email-custom-header templates"
+plugins_standard_always="bbdb subject-thread save-calendar select-one-source copy-tool mail-to-task audio-inline mailing-list-actions default-mailer import-ics-attachments prefer-plain mail-notification attachment-reminder face backup-restore email-custom-header templates"
plugins_standard="$plugins_standard_always"
all_plugins_standard="$plugins_standard"
@@ -2057,7 +2060,6 @@ plugins/subject-thread/Makefile
plugins/save-attachments/Makefile
plugins/save-calendar/Makefile
plugins/select-one-source/Makefile
-plugins/mark-calendar-offline/Makefile
plugins/prefer-plain/Makefile
plugins/profiler/Makefile
plugins/python/Makefile
@@ -2121,4 +2123,6 @@ echo "\
Plugins: $msg_plugins
DBus API version: $FOUND_DBUS_VERSION
User documentation: $with_help
+ Mono bindings: $enable_mono
+ Python bindings: $enable_python
"