aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 32 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1a3611e67c..273c05e1d5 100644
--- a/configure.in
+++ b/configure.in
@@ -655,7 +655,38 @@ dnl ******************************
AC_ARG_ENABLE(pilot-conduits,
[ --enable-pilot-conduits=[no/yes] Enable support for building pilot conduits.],,enable_pilot_conduits=no)
if test "x$enable_pilot_conduits" = "xyes"; then
-GNOME_PILOT_CHECK
+ GNOME_PILOT_CHECK
+
+ CFLAGS_save="$CFLAGS"
+ CFLAGS="$CFLAGS $PISOCK_CFLAGS"
+ LDFLAGS="$save_LDFLAGS"
+ LDFLAGS="$LDFLAGS $PISOCK_LIBS"
+
+ AC_CACHE_CHECK([if pilot-link handles UTF-8 conversions], ac_cv_pilot_link_utf8, AC_TRY_RUN([
+
+#include <stdlib.h>
+#include <string.h>
+#include <pi-util.h>
+
+int main (int argc, char **argv)
+{
+ const char *utf8 = "\x66\x66\x66\x66\x66\x66\x66\xC2\xA9";
+ size_t utf8_real_len = strlen (utf8);
+ char *pstring;
+
+ if (convert_ToPilotChar ("UTF8", utf8, utf8_real_len, &pstring) == -1)
+ exit (1);
+
+ exit (0);
+}
+], ac_cv_pilot_link_utf8=yes, ac_cv_pilot_link_utf8=no, ac_cv_pilot_link_utf8=no))
+
+ CFLAGS="$save_CFLAGS"
+ LDFLAGS="$save_LDFLAGS"
+
+ if test "$ac_cv_pilot_link_utf8" = no; then
+ AC_MSG_ERROR(evolution requires pilot-link to have working UTF-8 conversion routines)
+ fi
fi
AM_CONDITIONAL(ENABLE_PILOT_CONDUITS, test "x$enable_pilot_conduits" = "xyes")
if test x$enable_pilot_conduits = xyes; then