aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 35 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7c90b3a189..d7dd2f37ee 100644
--- a/configure.in
+++ b/configure.in
@@ -152,7 +152,41 @@ AC_SUBST(CAMEL_LOCK_HELPER_USER)
AC_SUBST(CAMEL_LOCK_HELPER_GROUP)
-EVO_TIMEZONE_CHECK
+dnl ***************
+dnl Timezone checks
+dnl ***************
+AC_CACHE_CHECK(for tm_gmtoff in struct tm, ac_cv_struct_tm_gmtoff,
+ AC_TRY_COMPILE([
+ #include <time.h>
+ ], [
+ struct tm tm;
+ tm.tm_gmtoff = 1;
+ ], ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no))
+if test $ac_cv_struct_tm_gmtoff = yes; then
+ AC_DEFINE(HAVE_TM_GMTOFF)
+else
+ AC_CACHE_CHECK(for timezone variable, ac_cv_var_timezone,
+ AC_TRY_COMPILE([
+ #include <time.h>
+ ], [
+ timezone = 1;
+ ], ac_cv_var_timezone=yes, ac_cv_var_timezone=no))
+ if test $ac_cv_var_timezone = yes; then
+ AC_DEFINE(HAVE_TIMEZONE)
+ AC_CACHE_CHECK(for altzone variable, ac_cv_var_altzone,
+ AC_TRY_COMPILE([
+ #include <time.h>
+ ], [
+ altzone = 1;
+ ], ac_cv_var_altzone=yes, ac_cv_var_altzone=no))
+ if test $ac_cv_var_altzone = yes; then
+ AC_DEFINE(HAVE_ALTZONE)
+ fi
+ else
+ AC_ERROR(unable to find a way to determine timezone)
+ fi
+fi
+
AC_CHECK_FUNCS(mkstemp mkdtemp isblank)