aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a1a70b705c..51f37c03e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,8 +71,7 @@ dnl ******************************
dnl Compiler Warning Flags
dnl ******************************
AS_COMPILER_FLAGS(WARNING_FLAGS,
- "-DEDS_DISABLE_DEPRECATED
- -DE_BOOK_DISABLE_DEPRECATED
+ "-DE_BOOK_DISABLE_DEPRECATED
-DE_CAL_DISABLE_DEPRECATED
-Wall -Wextra
-Wno-missing-field-initializers
@@ -87,6 +86,9 @@ AS_COMPILER_FLAGS(WARNING_FLAGS,
-Wredundant-decls -Wundef -Wwrite-strings")
AC_SUBST(WARNING_FLAGS)
+dnl Need to stop using e-passwords.h before we can restore
+dnl -DEDS_DISABLE_DEPRECATED
+
dnl Other useful compiler warnings for test builds only.
dnl These may produce warnings we have no control over,
dnl or false positives we don't always want to see.