aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab71306fde..436f54b72a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,6 +250,16 @@ PKG_CHECK_MODULES([GNOME_PLATFORM],
AC_SUBST(GNOME_PLATFORM_CFLAGS)
AC_SUBST(GNOME_PLATFORM_LIBS)
+dnl Blacklist WebKitGTK+ 1.9.90.
+if $PKG_CONFIG --exact-version "1.9.90" webkitgtk-3.0; then
+ AC_MSG_ERROR([
+
+ WebKitGTK+ 1.9.90 includes an unintentional API change
+ and is not usable with Evolution. Any other WebKitGTK+
+ release >= webkitgtk_minimum_version should work.
+])
+fi
+
PKG_CHECK_MODULES([EVOLUTION_DATA_SERVER],
[camel-1.2 >= eds_minimum_version
libebook-1.2 >= eds_minimum_version