aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 53be44215c..ea2e5ed5e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,7 +175,14 @@ dnl -DE_CAL_DISABLE_DEPRECATED
AM_CPPFLAGS="$WARNING_FLAGS -fno-strict-aliasing"
AC_SUBST(AM_CPPFLAGS)
-LDFLAGS="$LDFLAGS -Wl,--no-undefined"
+case "$host" in
+*openbsd*|*freebsd*)
+ dnl Do not set '-Wl,--no-undefined' on freebsd/openbsd
+ ;;
+*)
+ LDFLAGS="$LDFLAGS -Wl,--no-undefined"
+ ;;
+esac
AC_CANONICAL_HOST
AC_DEFINE_UNQUOTED(VERSION_COMMENT, "", [Define if you want a comment appended to the version number])