aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9109837366..63848be7a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,9 +11,10 @@ m4_define([evo_stable_version],
# Base Version: This is for API/version tracking for things like
# Bonobo server files. This should always be the major/minor of
-# the stable version or stable version to be.
+# the stable version or stable version to be. Note, this is set
+# the way it is so that GETTEXT_PACKAGE will be parsed correctly.
BASE_VERSION=2.28
-AC_SUBST([BASE_VERSION])
+m4_define([base_version], [2.28])
# Upgrade Revision: This is for triggering migration calls between
# varying versions. Reset to 0 whenever BASE_VERSION changes.
@@ -110,6 +111,7 @@ if test "$evo_version" != "$evo_stable_version"; then
[Define to the latest stable version if this version is unstable])
fi
+AC_SUBST([BASE_VERSION], [base_version])
AC_DEFINE_UNQUOTED(BASE_VERSION, ["$BASE_VERSION"], [Base version (Major.Minor)])
AC_SUBST([UPGRADE_REVISION],[upgrade_revision])