aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5d380f07e4..474d20b449 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,10 @@ dnl -DE_CAL_DISABLE_DEPRECATED
AM_CPPFLAGS="$WARNING_FLAGS -fno-strict-aliasing"
AC_SUBST(AM_CPPFLAGS)
+AC_CANONICAL_HOST
+AC_DEFINE_UNQUOTED(VERSION_COMMENT, "", [Define if you want a comment appended to the version number])
+
+dnl This must stay after AC_CANONICAL_HOST, which defines $host.
case "$host" in
*openbsd*|*freebsd*)
dnl Do not set '-Wl,--no-undefined' on freebsd/openbsd
@@ -110,8 +114,6 @@ case "$host" in
;;
esac
-AC_CANONICAL_HOST
-AC_DEFINE_UNQUOTED(VERSION_COMMENT, "", [Define if you want a comment appended to the version number])
dnl *************************************
dnl Put the ACLOCAL flags in the Makefile
@@ -203,6 +205,15 @@ case "$host" in
CHAMPLAIN_REQUIREMENT=''
GEOCLUE_REQUIREMENT=''
;;
+*openbsd*|*freebsd*)
+ os_win32=no
+ NO_UNDEFINED=''
+ SOEXT='.so'
+ SA_JUNK_PLUGIN=sa-junk-plugin
+ BF_JUNK_PLUGIN=bogo-junk-plugin
+ DL_LIB=''
+ SOFTOKN3_LIB='-lsoftokn3'
+ ;;
*)
os_win32=no
NO_UNDEFINED='-no-undefined'