aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bb82419c13..2ee9683026 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,7 @@ AS_COMPILER_FLAGS(WARNING_FLAGS,
-DGDK_PIXBUF_DISABLE_DEPRECATED
-DGDK_DISABLE_DEPRECATED
-DGTK_DISABLE_DEPRECATED
+ -DEDS_DISABLE_DEPRECATED
-DG_DISABLE_SINGLE_INCLUDES
-DGTK_DISABLE_SINGLE_INCLUDES
-Wall -Wextra
@@ -1175,10 +1176,21 @@ if test "$enable_sens" = yes; then
AC_SUBST(HAVE_SENS)
AC_SUBST(SENS_LIBS)
fi
-
AM_CONDITIONAL([ENABLE_WINDOWS_SENS], [test "$enable_sens" = yes])
dnl ******************************
+dnl Enable ConnMan support ?
+dnl ******************************
+AC_ARG_ENABLE([connman],
+ [AS_HELP_STRING([--enable-connman],
+ [enable ConnMan support (default=no)])],
+ [enable_connman=$enableval],[enable_connman=no])
+if test "x$enable_nm$enable_connman" = "xyesyes"; then
+ AC_MSG_ERROR([It is not possible to enable both ConnMan and NetworkManager])
+fi
+AM_CONDITIONAL([ENABLE_CONNMAN], [test "$enable_connman" = yes])
+
+dnl ******************************
dnl Camel Flags
dnl ******************************
EVO_SET_COMPILE_FLAGS(CAMEL, camel-provider-1.2, $MANUAL_NSS_CFLAGS, $MOXILLA_NSS_CFLAGS)
@@ -1726,6 +1738,7 @@ modules/addressbook/Makefile
modules/calendar/Makefile
modules/mail/Makefile
modules/network-manager/Makefile
+modules/connman/Makefile
modules/plugin-lib/Makefile
modules/plugin-mono/Makefile
modules/plugin-python/Makefile
@@ -1777,6 +1790,7 @@ smime/gui/Makefile
sounds/Makefile
capplet/Makefile
capplet/settings/Makefile
+capplet/settings/mail-autoconfig/Makefile
evolution-zip
evolution-calendar.pc
evolution-mail.pc
@@ -1798,6 +1812,7 @@ echo "
LDAP support: $msg_ldap
NetworkManager: $enable_nm
Windows SENS: $enable_sens
+ ConnMan: $enable_connman
Pilot conduits: $msg_pilot
Libnotify: $HAVE_LIBNOTIFY
Kerberos 5: $msg_krb5