aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b3d6e4c3e8..f9938df788 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1175,7 +1175,25 @@ if test "$enable_sens" = yes; then
AC_SUBST(HAVE_SENS)
AC_SUBST(SENS_LIBS)
fi
-
+AC_MSG_CHECKING([if Windows SENS support is enabled])
+AC_MSG_RESULT([$enable_sens])
+if test "$enable_sens" = yes; then
+ SENS_LIBS="-lole32 -loleaut32 -luuid -lrpcrt4"
+ AC_CHECK_HEADER([eventsys.h],
+ [AC_DEFINE([HAVE_EVENTSYS_H], 1, [Have <eventsys.h>])],,
+ [[ #if HAVE_EVENTSYS_H
+ #include <eventsys.h>
+ #endif
+ ]])
+ AC_CHECK_HEADER([sensevts.h],
+ [AC_DEFINE([HAVE_SENSEVTS_H], 1, [Have <sensevts.h>])],,
+ [[ #if HAVE_SENSEVTS_H
+ #include <sensevts.h>
+ #endif
+ ]])
+ AC_SUBST(HAVE_SENS)
+ AC_SUBST(SENS_LIBS)
+fi
AM_CONDITIONAL([ENABLE_WINDOWS_SENS], [test "$enable_sens" = yes])
dnl ******************************
@@ -1835,6 +1853,7 @@ echo "
LDAP support: $msg_ldap
NetworkManager: $enable_nm
Windows SENS: $enable_sens
+ ConnMan: $enable_connman
Pilot conduits: $msg_pilot
Libnotify: $HAVE_LIBNOTIFY
Kerberos 5: $msg_krb5