aboutsummaryrefslogtreecommitdiffstats
path: root/camel/tests/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camel/tests/lib/Makefile.am')
-rw-r--r--camel/tests/lib/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/camel/tests/lib/Makefile.am b/camel/tests/lib/Makefile.am
index 93ec07abd5..4b9613e66d 100644
--- a/camel/tests/lib/Makefile.am
+++ b/camel/tests/lib/Makefile.am
@@ -5,9 +5,10 @@ INCLUDES = \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/e-util \
-I$(top_srcdir)/camel \
+ -DCAMEL_BUILD_DIR=\"$(top_builddir)/camel\" \
$(CAMEL_CFLAGS)
-check_LIBRARIES = libcameltest.a
+check_LIBRARIES = libcameltest.a libcameltest-provider.a
libcameltest_a_SOURCES = \
camel-test.c camel-test.h \
@@ -18,5 +19,14 @@ libcameltest_a_SOURCES = \
streams.c streams.h \
address-data.h
+libcameltest_provider_a_SOURCES = \
+ camel-test-provider.c camel-test-provider.h
+
libcameltest_a_LIBADD = \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/libedataserver/libedataserver-${BASE_VERSION}.la
+
+libcameltest_provider_a_LIBADD = \
+ $(top_builddir)/camel/libcamel-provider.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/libedataserver/libedataserver-${BASE_VERSION}.la