aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/nntp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camel/providers/nntp/Makefile.am')
-rw-r--r--camel/providers/nntp/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/camel/providers/nntp/Makefile.am b/camel/providers/nntp/Makefile.am
index 48f85e836d..a205f5bb83 100644
--- a/camel/providers/nntp/Makefile.am
+++ b/camel/providers/nntp/Makefile.am
@@ -17,15 +17,28 @@ INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
libcamelnntp_la_SOURCES = \
camel-nntp-folder.c \
+ camel-nntp-newsrc.c \
camel-nntp-provider.c \
camel-nntp-store.c \
camel-nntp-utils.c
libcamelnntpinclude_HEADERS = \
camel-nntp-folder.h \
+ camel-nntp-newsrc.h \
camel-nntp-store.h
-
libcamelnntp_la_LDFLAGS = -version-info 0:0:0
EXTRA_DIST = libcamelnntp.urls
+
+noinst_PROGRAMS = test-newsrc
+
+LDADD = \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(GNOME_LIBDIR) \
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(EXTRA_GNOME_LIBS)
+# $(BONOBO_LIBS)
+
+test_newsrc_LDADD = libcamelnntp.la $(LDADD)