aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index 0c9800bd4d..0c7590f91a 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -31,12 +31,12 @@ $(CORBA_GENERATED): $(idls)
pcsincludedir = $(includedir)/evolution/pcs
privlib_LIBRARIES = libpcs.a
+noinst_LIBRARIES = libpcsfile.a
pcsinclude_HEADERS = \
$(CORBA_GENERATED_H) \
cal.h \
cal-backend.h \
- cal-backend-file.h \
cal-backend-util.h \
cal-common.h \
cal-factory.h \
@@ -48,12 +48,15 @@ libpcs_a_SOURCES = \
$(CORBA_GENERATED_C) \
cal.c \
cal-backend.c \
- cal-backend-file.c \
cal-backend-util.c \
cal-factory.c \
job.c \
query.c
+libpcsfile_a_SOURCES = \
+ cal-backend-file.c \
+ cal-backend-file.h
+
BUILT_SOURCES = $(CORBA_GENERATED)
CLEANFILES = $(BUILT_SOURCES)