aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index fa15a9286e..5d2804c6f5 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -206,3 +206,15 @@ EXTRA_DIST = \
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(help_base)/C
# $(mkinstalldirs) $(Conduitsdir)
+
+if ENABLE_PURIFY
+PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+
+all-local: evolution-calendar.pure
+
+evolution-calendar.pure: evolution-calendar
+ @rm -f evolution-calendar.pure
+ $(PLINK) $(evolution_calendar_LDFLAGS) $(evolution_calendar_OBJECTS) $(evolution_calendar_LDADD) $(LIBS)
+
+endif
+