aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index cffe6aaa22..3d13df9148 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -6,6 +6,10 @@ help_base = $(datadir)/gnome/help/cal
# calendar-pilot-sync
#endif
+
+CPPFLAGS = \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\"
+
INCLUDES = \
-DG_LOG_DOMAIN=\"calendar-gui\" \
-I$(top_srcdir) \
@@ -15,6 +19,7 @@ INCLUDES = \
$(BONOBO_VFS_GNOME_CFLAGS) \
$(GNOME_CONDUIT_INCLUDEDIR) \
$(PISOCK_INCLUDEDIR) \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
LINK_FLAGS = \
@@ -27,6 +32,9 @@ LINK_FLAGS = \
$(top_builddir)/libversit/libversit.la \
$(top_builddir)/libical/src/libical/libical.la
+gladedir = $(datadir)/evolution/glade
+glade_DATA = event-editor-dialog.glade
+
bin_PROGRAMS = evolution-calendar
evolution_calendar_SOURCES = \
@@ -48,8 +56,8 @@ evolution_calendar_SOURCES = \
e-week-view-titles-item.h \
e-week-view.c \
e-week-view.h \
- eventedit.c \
- eventedit.h \
+ event-editor-utils.c \
+ event-editor-utils.h \
getdate.y \
gncal-todo.c \
gncal-todo.h \
@@ -70,8 +78,18 @@ evolution_calendar_SOURCES = \
year-view.h \
calendar-commands.c \
calendar-commands.h \
+ event-editor.c \
+ event-editor.h \
evolution-calendar-control.c
+# eventedit.c \
+# eventedit.h \
+
+
+
+
+
+
evolution_calendar_LDADD = \
$(EXTRA_GNOME_LIBS) \
$(BONOBO_HTML_GNOME_LIBS) \