aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 8e2ea78dde..da5a843d0b 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -5,6 +5,8 @@ idl_DATA = \
GnomeCal.idl \
evolution-calendar.idl
+idl_flags = `$(GNOME_CONFIG) --cflags idl`
+
gnorbadir = $(sysconfdir)/CORBA/servers
gnorba_DATA = \
gnomecal.gnorba \
@@ -20,6 +22,8 @@ endif
bin_PROGRAMS = gnomecal tlacuache $(extra_pilot_bins)
+lib_LTLIBRARIES = libcal-client.la
+
ICAL_LINK_FLAGS = ../libical/src/libical/libical.la
INCLUDES = \
@@ -38,7 +42,7 @@ GNOMECAL_CORBA_GENERATED = \
GnomeCal-stubs.c
$(GNOMECAL_CORBA_GENERATED): GnomeCal.idl
- orbit-idl $(srcdir)/GnomeCal.idl
+ $(ORBIT_IDL) $(idl_flags) $(srcdir)/GnomeCal.idl
corba-cal.c \
corba-cal.h \
@@ -52,7 +56,7 @@ EVOLUTION_CALENDAR_CORBA_GENERATED = \
evolution-calendar-stubs.c
$(EVOLUTION_CALENDAR_CORBA_GENERATED): evolution-calendar.idl
- orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl $(srcdir)/evolution-calendar.idl
+ $(ORBIT_IDL) $(idl_flags) $(srcdir)/evolution-calendar.idl
gnomecal_SOURCES = \
$(EVOLUTION_CALENDAR_CORBA_GENERATED) \
@@ -129,6 +133,27 @@ calendar_pilot_sync_SOURCES = \
timeutil.c \
timeutil.h
+#
+# cal-client library
+#
+
+libcal_clientincludedir = $(includedir)/cal-client
+
+libcal_client_la_SOURCES = \
+ $(EVOLUTION_CALENDAR_CORBA_GENERATED) \
+ cal-client.c \
+ cal-listener.c \
+ cal-util.c
+
+libcal_clientinclude_HEADERS = \
+ cal-client.h \
+ cal-listener.h \
+ cal-util.h
+
+#
+# tlacuache personal calendar server
+#
+
tlacuache_SOURCES = \
$(EVOLUTION_CALENDAR_CORBA_GENERATED) \
alarm.c \