aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 08c4a2dcb4..8c0a6ff561 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -207,19 +207,29 @@ server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
+# GConf schemas
+
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_DATA = apps_evolution_calendar.schemas
+
@INTLTOOL_SERVER_RULE@
EXTRA_DIST = \
$(glade_DATA) \
+ $(schema_DATA) \
$(etspec_DATA) \
$(server_in_files)
BUILT_SOURCES = $(IDL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
-
install-data-local:
- $(mkinstalldirs) $(Conduitsdir)
+ $(mkinstalldirs) $(Conduitsdir); \
+ if test -z "$(DESTDIR)"; then \
+ for p in $(schema_DATA); do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ done; \
+ fi
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)