aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/cal-client/Makefile.am')
-rw-r--r--calendar/cal-client/Makefile.am30
1 files changed, 16 insertions, 14 deletions
diff --git a/calendar/cal-client/Makefile.am b/calendar/cal-client/Makefile.am
index b8190fe5aa..9008c05940 100644
--- a/calendar/cal-client/Makefile.am
+++ b/calendar/cal-client/Makefile.am
@@ -1,6 +1,19 @@
-#
-# libcal-client
-#
+INCLUDES = \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DG_LOG_DOMAIN=\"cal-client\" \
+ -I$(top_srcdir)/calendar \
+ -I$(srcdir) -I$(top_srcdir) \
+ -I. \
+ -I.. \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/libical/src \
+ $(EVOLUTION_CALENDAR_CFLAGS)
+
+AM_CFLAGS = \
+ -DGTK_DISABLE_DEPRECATED=1 \
+ -DGDK_DISABLE_DEPRECATED=1 \
+ -DG_DISABLE_DEPRECATED=1 \
+ -DGNOME_DISABLE_DEPRECATED=1
CORBA_GENERATED_C = \
evolution-calendar-common.c \
@@ -20,17 +33,6 @@ $(CORBA_GENERATED_H): $(idls)
$(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
$(CORBA_GENERATED_C): $(CORBA_GENERATED_H)
-INCLUDES = \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DG_LOG_DOMAIN=\"cal-client\" \
- -I$(top_srcdir)/calendar \
- -I$(srcdir) -I$(top_srcdir) \
- -I. \
- -I.. \
- -I$(top_builddir) \
- -I$(top_srcdir)/libical/src \
- $(EVOLUTION_CALENDAR_CFLAGS)
-
privlib_LTLIBRARIES = libcal-client.la
libcal_clientincludedir = $(privincludedir)/cal-client