aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/Makefile.am')
-rw-r--r--calendar/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/calendar/Makefile.am b/calendar/Makefile.am
index 9e74d29e99..56acae59c8 100644
--- a/calendar/Makefile.am
+++ b/calendar/Makefile.am
@@ -6,7 +6,20 @@ endif
SUBDIRS = idl common gui importers $(CONDUIT_DIR)
+error_DATA = calendar-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
+errordir = $(privdatadir)/errors
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
+
EXTRA_DIST = \
ChangeLog.pre-1-4 \
+ $(error_DATA) \
zones.h
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
+BUILT_SOURCES = $(error_i18n)
+
+CLEANFILES = $(BUILT_SOURCES)