aboutsummaryrefslogtreecommitdiffstats
path: root/art/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'art/Makefile.am')
-rw-r--r--art/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/art/Makefile.am b/art/Makefile.am
index f2a365fd46..e15280daa0 100644
--- a/art/Makefile.am
+++ b/art/Makefile.am
@@ -1,4 +1,4 @@
-imagesdir = $(datadir)/evolution/images/
+imagesdir = $(datadir)/evolution-$(BASE_VERSION)/images/
images_DATA = \
16_copy.png \
16_customize.png \
@@ -166,7 +166,7 @@ images_DATA = \
working-16.png \
world_map-960.png
-buttonsdir = $(datadir)/evolution/images/buttons
+buttonsdir = $(datadir)/evolution-$(BASE_VERSION)/images/buttons
buttons_DATA = \
arrow-right-24.png \
arrow-left-24.png \
@@ -200,7 +200,7 @@ buttons_DATA = \
workweekview.xpm \
yearview.xpm
-gladedir = $(datadir)/evolution/glade
+gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = \
evolution.png \
import.png \
@@ -213,7 +213,7 @@ glade_DATA = \
thankyou.png \
timezone-48.png
-conduitsdir = $(datadir)/evolution/images/conduits
+conduitsdir = $(datadir)/evolution-$(BASE_VERSION)/images/conduits
conduits_DATA = \
evo-16-address-conduit.png \
evo-16-todo-conduit.png \
@@ -222,14 +222,16 @@ conduits_DATA = \
evo-48-address-conduit.png \
evo-48-todo-conduit.png
-appicondir = $(datadir)/pixmaps
-appicon_DATA = evolution.png
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps; \
+ $(INSTALL_DATA) $(srcdir)/evolution.png $(DESTDIR)$(datadir)/pixmaps/evolution-$(BASE_VERSION).png
-EXTRA_DIST = \
+EXTRA_DIST = \
attachment.xpm \
bell.xpm \
check-filled.xpm \
empty.xpm \
+ evolution.png \
jump.xpm \
mail-need-reply.xpm \
mail-new.xpm \
@@ -256,5 +258,4 @@ EXTRA_DIST = \
$(images_DATA) \
$(buttons_DATA) \
$(conduits_DATA) \
- $(glade_DATA) \
- $(appicon_DATA)
+ $(glade_DATA)