aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/tools/Makefile.am')
-rw-r--r--addressbook/tools/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/addressbook/tools/Makefile.am b/addressbook/tools/Makefile.am
index 79a1c746ad..c9e082603e 100644
--- a/addressbook/tools/Makefile.am
+++ b/addressbook/tools/Makefile.am
@@ -1,6 +1,12 @@
+privlibexec_SCRIPTS = \
+ csv2vcard \
+ evolution-addressbook-clean
+
bin_PROGRAMS = \
evolution-addressbook-export
+noinst_PROGRAMS= evolution-addressbook-abuse
+
INCLUDES = \
-DG_LOG_DOMAIN=\"evolution-addressbook-tools\" \
-I$(top_srcdir) \
@@ -23,11 +29,22 @@ evolution_addressbook_export_SOURCES = \
evolution-addressbook-export.h
evolution_addressbook_export_LDADD = \
- $(GNOME_FULL_LIBS) \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
- $(top_builddir)/widgets/menus/libmenus.la \
- $(top_builddir)/camel/libcamel.la \
- $(top_builddir)/libversit/libversit.la \
$(top_builddir)/e-util/ename/libename.la \
$(top_builddir)/e-util/libeutil.la
+evolution_addressbook_abuse_LDADD = \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/e-util/libeutil.la
+
+EXTRA_DIST = $(privlibexec_SCRIPTS) \
+ evolution-addressbook-clean.in
+
+CLEANFILES= evolution-addressbook-clean
+
+evolution-addressbook-clean: evolution-addressbook-clean.in Makefile
+## Use sed and then mv to avoid problems if the user interrupts.
+ sed -e 's?\@EVOLUTION_TOOLSDIR\@?$(privlibexecdir)?g' \
+ < $(srcdir)/evolution-addressbook-clean.in > evolution-addressbook-clean.tmp \
+ && mv evolution-addressbook-clean.tmp evolution-addressbook-clean