aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
new file mode 100644
index 0000000000..4fabafafd3
--- /dev/null
+++ b/addressbook/printing/Makefile.am
@@ -0,0 +1,33 @@
+
+CPPFLAGS = \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ $(GNOME_PRINT_CFLAGS)
+
+INCLUDES = \
+ $(GNOME_INCLUDEDIR)
+
+noinst_LIBRARIES = \
+ libecontactprint.a
+
+libecontactprint_a_SOURCES = \
+ e-contact-print.c \
+ e-contact-print.h \
+ e-contact-print-types.h
+
+noinst_PROGRAMS = \
+ contact-print-test
+
+contact_print_test_SOURCES = \
+ test-print.c
+
+contact_print_test_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ libecontactprint.a \
+ $(GNOME_PRINT_LIBS)
+
+gladedir = $(datadir)/evolution/glade
+
+#glade_DATA = \
+# e-contact-print.glade
+