aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am21
1 files changed, 14 insertions, 7 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
index 5304e21c01..2c0d824c93 100644
--- a/addressbook/printing/Makefile.am
+++ b/addressbook/printing/Makefile.am
@@ -4,7 +4,8 @@ ecps_DATA = \
medbook.ecps \
phonelist.ecps
-AM_CPPFLAGS = \
+libecontactprint_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
-DG_LOG_DOMAIN=\"addressbook-printing\" \
-I$(top_srcdir)/addressbook \
-I$(top_srcdir) \
@@ -12,8 +13,7 @@ AM_CPPFLAGS = \
-DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
-noinst_LTLIBRARIES = \
- libecontactprint.la
+noinst_LTLIBRARIES = libecontactprint.la
libecontactprint_la_SOURCES = \
e-contact-print-types.h \
@@ -24,11 +24,18 @@ libecontactprint_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la
-noinst_PROGRAMS = \
- contact-print-test
+noinst_PROGRAMS = contact-print-test
-contact_print_test_SOURCES = \
- test-print.c
+contact_print_test_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DG_LOG_DOMAIN=\"addressbook-printing\" \
+ -I$(top_srcdir)/addressbook \
+ -I$(top_srcdir) \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
+ $(EVOLUTION_ADDRESSBOOK_CFLAGS)
+
+contact_print_test_SOURCES = test-print.c
contact_print_test_LDADD = \
libecontactprint.la \