aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
index 217a4288fb..04b72bfa4a 100644
--- a/addressbook/printing/Makefile.am
+++ b/addressbook/printing/Makefile.am
@@ -9,8 +9,9 @@ libecontactprint_la_CPPFLAGS = \
-DG_LOG_DOMAIN=\"addressbook-printing\" \
-I$(top_srcdir)/addressbook \
-I$(top_srcdir) \
- -DEVOLUTION_UIDIR=\""$(uidir)"\" \
+ -DEVOLUTION_UIDIR=\""$(uidir)"\" \
-DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
+ $(GNOME_PLATFORM_CFLAGS) \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
noinst_LTLIBRARIES = libecontactprint.la
@@ -22,7 +23,8 @@ libecontactprint_la_SOURCES = \
libecontactprint_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/widgets/misc/libemiscwidgets.la
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(GNOME_PLATFORM_LIBS)
noinst_PROGRAMS = contact-print-test
@@ -33,6 +35,7 @@ contact_print_test_CPPFLAGS = \
-I$(top_srcdir) \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
+ $(GNOME_PLATFORM_CFLAGS) \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
contact_print_test_SOURCES = test-print.c
@@ -42,7 +45,8 @@ contact_print_test_LDADD = \
$(top_builddir)/addressbook/util/libeabutil.la \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/shell/libeshell.la \
- $(EVOLUTION_ADDRESSBOOK_LIBS)
+ $(EVOLUTION_ADDRESSBOOK_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
EXTRA_DIST = \
$(ecps_DATA)