aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-list-editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/contact-list-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-list-editor/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/addressbook/gui/contact-list-editor/Makefile.am b/addressbook/gui/contact-list-editor/Makefile.am
index c87f352879..b469b2a330 100644
--- a/addressbook/gui/contact-list-editor/Makefile.am
+++ b/addressbook/gui/contact-list-editor/Makefile.am
@@ -21,9 +21,25 @@ noinst_LIBRARIES = \
libecontactlisteditor_a_SOURCES = \
e-contact-list-editor.c \
e-contact-list-editor.h \
+ e-contact-list-editor-marshal.c \
e-contact-list-model.c \
e-contact-list-model.h
+# GLib marshalling cruft
+
+e-contact-list-editor-marshal.h: e-contact-list-editor-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=ecle_marshal e-contact-list-editor-marshal.list --header > e-contact-list-editor-marshal.tmp \
+ && mv e-contact-list-editor-marshal.tmp e-contact-list-editor-marshal.h ) \
+ || ( rm -f e-contact-list-editor-marshal.tmp && exit 1 )
+
+e-contact-list-editor-marshal.c: e-contact-list-editor-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=ecle_marshal e-contact-list-editor-marshal.list --body > e-contact-list-editor-marshal.tmp \
+ && mv e-contact-list-editor-marshal.tmp e-contact-list-editor-marshal.c ) \
+ || ( rm -f e-contact-list-editor-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-contact-list-editor-marshal.c e-contact-list-editor-marshal.h
+
+
iconsdir = $(datadir)/images/evolution
gladedir = $(datadir)/evolution/glade
@@ -34,5 +50,9 @@ glade_DATA = \
etspecdir = $(datadir)/evolution/etspec
etspec_DATA = e-contact-list-editor.etspec
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
EXTRA_DIST = $(glade_DATA) \
- $(etspec_DATA)
+ $(etspec_DATA) \
+ e-contact-list-editor-marshal.list