aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-list-editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/contact-list-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-list-editor/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/addressbook/gui/contact-list-editor/Makefile.am b/addressbook/gui/contact-list-editor/Makefile.am
index 10069eaca1..71516c33bb 100644
--- a/addressbook/gui/contact-list-editor/Makefile.am
+++ b/addressbook/gui/contact-list-editor/Makefile.am
@@ -1,22 +1,20 @@
+if OS_WIN32
+WIN32_BOOTSTRAP_LIBS = $(top_builddir)/win32/libevolution-addressbook.la
+endif
+
INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
-I$(top_srcdir)/addressbook/ \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
-I$(top_srcdir)/addressbook/gui/merging \
-I$(top_srcdir)/addressbook/gui/contact-editor \
-I$(top_builddir)/shell \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
- -DEVOLUTION_UIDIR=\""$(evolutionuidir)\"" \
- -DPREFIX=\""$(prefix)"\" \
-DG_LOG_DOMAIN=\"contact-list-editor\" \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
-privlib_LTLIBRARIES = \
+privsolib_LTLIBRARIES = \
libecontactlisteditor.la
libecontactlisteditor_la_SOURCES = \
@@ -26,6 +24,17 @@ libecontactlisteditor_la_SOURCES = \
e-contact-list-model.c \
e-contact-list-model.h
+libecontactlisteditor_la_LDFLAGS = $(NO_UNDEFINED)
+
+libecontactlisteditor_la_LIBADD = \
+ $(WIN32_BOOTSTRAP_LIBS) \
+ $(top_builddir)/addressbook/util/libeabutil.la \
+ $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
+ $(top_builddir)/widgets/table/libetable.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_ADDRESSBOOK_LIBS)
+
MARSHAL_GENERATED = e-contact-list-editor-marshal.c e-contact-list-editor-marshal.h
@EVO_MARSHAL_RULE@