aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/contact-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-editor/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/addressbook/gui/contact-editor/Makefile.am b/addressbook/gui/contact-editor/Makefile.am
index fe7295bfe6..fb61b1a97b 100644
--- a/addressbook/gui/contact-editor/Makefile.am
+++ b/addressbook/gui/contact-editor/Makefile.am
@@ -22,6 +22,7 @@ libecontacteditor_a_SOURCES = \
e-contact-editor-address.h \
e-contact-editor-fullname.c \
e-contact-editor-fullname.h \
+ e-contact-editor-marshal.c \
e-contact-editor.c \
e-contact-editor.h \
e-contact-save-as.c \
@@ -29,6 +30,20 @@ libecontacteditor_a_SOURCES = \
e-contact-quick-add.c \
e-contact-quick-add.h
+# GLib marshalling cruft
+
+e-contact-editor-marshal.h: e-contact-editor-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=ece_marshal e-contact-editor-marshal.list --header > e-contact-editor-marshal.tmp \
+ && mv e-contact-editor-marshal.tmp e-contact-editor-marshal.h ) \
+ || ( rm -f e-contact-editor-marshal.tmp && exit 1 )
+
+e-contact-editor-marshal.c: e-contact-editor-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=ece_marshal e-contact-editor-marshal.list --body > e-contact-editor-marshal.tmp \
+ && mv e-contact-editor-marshal.tmp e-contact-editor-marshal.c ) \
+ || ( rm -f e-contact-editor-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-contact-editor-marshal.c e-contact-editor-marshal.h
+
evolutiondir = $(datadir)/evolution
evolution_DATA = arrow.png
@@ -44,5 +59,9 @@ glade_DATA = \
file-exists.glade \
e-contact-editor-confirm-delete.glade
-EXTRA_DIST = $(evolution_DATA) \
- $(glade_DATA)
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST= $(evolution_DATA) \
+ $(glade_DATA) \
+ e-contact-editor-marshal.list