aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/select-names/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/component/select-names/Makefile.am')
-rw-r--r--addressbook/gui/component/select-names/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/addressbook/gui/component/select-names/Makefile.am b/addressbook/gui/component/select-names/Makefile.am
index ad3bb4f8f0..5972f3f4db 100644
--- a/addressbook/gui/component/select-names/Makefile.am
+++ b/addressbook/gui/component/select-names/Makefile.am
@@ -1,5 +1,7 @@
# CORBA stuff
+componentdir = $(COMPONENT_DIR)
+
idl_DATA = \
Evolution-Addressbook-SelectNames.idl
@@ -20,7 +22,7 @@ server_in_files = GNOME_Evolution_Addressbook_SelectNames.server.in.in
serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+ sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
@@ -56,8 +58,6 @@ libeselectnames_la_SOURCES = \
e-select-names-bonobo.h \
e-select-names-completion.c \
e-select-names-completion.h \
- e-select-names-factory.c \
- e-select-names-factory.h \
e-select-names-manager.c \
e-select-names-manager.h \
e-select-names-marshal.c \
@@ -74,6 +74,12 @@ libeselectnames_la_SOURCES = \
e-simple-card-bonobo.c \
e-simple-card-bonobo.h
+# We'll need these again when we split out the select names control
+# into its own shlib factory, but for now they're redundant.
+#
+# e-select-names-factory.c
+# e-select-names-factory.h
+
# GLib marshalling cruft
e-select-names-marshal.h: e-select-names-marshal.list