aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/select-names/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/component/select-names/Makefile.am')
-rw-r--r--addressbook/gui/component/select-names/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/addressbook/gui/component/select-names/Makefile.am b/addressbook/gui/component/select-names/Makefile.am
index 347af45f74..c12027c49d 100644
--- a/addressbook/gui/component/select-names/Makefile.am
+++ b/addressbook/gui/component/select-names/Makefile.am
@@ -1,6 +1,8 @@
# CORBA stuff
-IDLS = \
+idldir = $(datadir)/idl
+
+idl_DATA = \
Evolution-Addressbook-SelectNames.idl
IDL_GENERATED = \
@@ -11,7 +13,7 @@ IDL_GENERATED = \
Evolution-Addressbook-SelectNames-impl.o: Evolution-Addressbook-SelectNames.h
-$(IDL_GENERATED): $(IDLS)
+$(IDL_GENERATED): $(idl_DATA)
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
$(srcdir)/Evolution-Addressbook-SelectNames.idl
@@ -75,8 +77,7 @@ glade_DATA = select-names.glade
EXTRA_DIST = \
$(glade_DATA) \
$(oaf_in_files) \
- $(oaf_DATA) \
- $(IDLS)
+ $(oaf_DATA)
BUILT_SOURCES = $(IDL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)