aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
new file mode 100644
index 0000000000..f5269071c4
--- /dev/null
+++ b/addressbook/gui/component/Makefile.am
@@ -0,0 +1,36 @@
+INCLUDES = \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ -I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/addressbook/gui/minicard \
+ -I$(top_srcdir)/addressbook/backend/ebook \
+ $(BONOBO_HTML_GNOME_CFLAGS) \
+ -DEVOLUTION_VERSION=\""$(VERSION)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
+
+bin_PROGRAMS = \
+ evolution-addressbook
+
+evolution_addressbook_SOURCES = \
+ addressbook-factory.c \
+ addressbook.c \
+ addressbook.h
+
+evolution_addressbook_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
+ $(top_builddir)/addressbook/gui/minicard/libeminicard.a \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/libversit/libversit.la
+
+evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+gnorbadir = $(sysconfdir)/CORBA/servers
+gnorba_DATA = addressbook.gnorba