aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/demo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/demo/Makefile.am')
-rw-r--r--addressbook/demo/Makefile.am35
1 files changed, 33 insertions, 2 deletions
diff --git a/addressbook/demo/Makefile.am b/addressbook/demo/Makefile.am
index 27b438549c..4a7f39a503 100644
--- a/addressbook/demo/Makefile.am
+++ b/addressbook/demo/Makefile.am
@@ -5,21 +5,52 @@ INCLUDES = \
-I$(top_srcdir)/e-util \
-I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir) \
- -I$(top_srcdir)/widgets/e-minicard
+ -I$(top_srcdir)/widgets/e-minicard \
+ $(BONOBO_HTML_GNOME_CFLAGS) \
+ -DEVOLUTION_VERSION=\""$(VERSION)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
noinst_PROGRAMS = \
+ test-addressbook
+
+test_addressbook_SOURCES = \
+ demo.c \
+ e-test-model.c \
+ e-test-model.h
+
+test_addressbook_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/widgets/e-minicard/libeminicard.a \
+ $(top_builddir)/widgets/e-table/libetable.a \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/e-util/libeutil.la
+
+test_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+bin_PROGRAMS = \
evolution-addressbook
evolution_addressbook_SOURCES = \
- demo.c \
+ addressbook-factory.c \
+ addressbook-widget.c \
+ addressbook-widget.h \
+ addressbook.c \
+ addressbook.h \
e-test-model.c \
e-test-model.h
evolution_addressbook_LDADD = \
$(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/widgets/e-minicard/libeminicard.a \
$(top_builddir)/widgets/e-table/libetable.a \
$(top_builddir)/widgets/e-text/libetext.a \
$(top_builddir)/e-util/libeutil.la
evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+gnorbadir = $(sysconfdir)/CORBA/servers
+gnorba_DATA = addressbook.gnorba