aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/pas/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/backend/pas/Makefile.am')
-rw-r--r--addressbook/backend/pas/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/addressbook/backend/pas/Makefile.am b/addressbook/backend/pas/Makefile.am
index 69fdeb41a7..8f4f8a3731 100644
--- a/addressbook/backend/pas/Makefile.am
+++ b/addressbook/backend/pas/Makefile.am
@@ -20,8 +20,12 @@ INCLUDES = \
-I$(top_builddir)/addressbook/backend \
$(BONOBO_GNOME_CFLAGS)
+LDAP_BACKEND_SOURCES = pas-backend-ldap.c pas-backend-ldap.h
+
if ENABLE_LDAP
-LDAP_BACKEND = pas-backend-ldap.c pas-backend-ldap.h
+LDAP_BACKEND = $(LDAP_BACKEND_SOURCES)
+else
+LDAP_BACKEND =
endif
noinst_LIBRARIES = libpas.a
@@ -44,3 +48,5 @@ libpas_a_SOURCES = \
BUILT_SOURCES = $(CORBA_SOURCE)
CLEANFILES += $(BUILT_SOURCES)
+
+EXTRA_DIST = $(LDAP_BACKEND_SOURCES) \ No newline at end of file