aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
index e9e974b704..35cf59d537 100644
--- a/addressbook/backend/ebook/Makefile.am
+++ b/addressbook/backend/ebook/Makefile.am
@@ -1,3 +1,5 @@
+bin_PROGRAMS = test-card test-client
+
corbadir = $(sysconfdir)/CORBA/servers
CORBA_SOURCE = \
@@ -39,7 +41,8 @@ lib_LTLIBRARIES = libebook.la
libebook_la_SOURCES = \
$(CORBA_SOURCE) \
e-book-listener.c \
- e-book.c
+ e-book.c \
+ e-card.c
libebookincludedir = $(includedir)/backend
@@ -48,5 +51,29 @@ libebookinclude_HEADERS = \
e-book-listener.h \
e-card.h
+test_client_SOURCES = \
+ test-client.c
+
+test_client_LDADD = \
+ $(GTK_LIBS) \
+ $(GNOME_LIBDIR) \
+ $(GNOMEGNORBA_LIBS) \
+ $(INTLLIBS) \
+ -lbonobo \
+ $(ebook_libs) \
+ ../libversit/libversit.la
+
+test_card_SOURCES = \
+ test-card.c
+
+test_card_LDADD = \
+ $(GTK_LIBS) \
+ $(GNOME_LIBDIR) \
+ $(GNOMEGNORBA_LIBS) \
+ $(INTLLIBS) \
+ -lbonobo \
+ $(ebook_libs) \
+ ../libversit/libversit.la
+
BUILT_SOURCES = $(CORBA_SOURCE)
CLEANFILES += $(BUILT_SOURCES)