aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
new file mode 100644
index 0000000000..e9e974b704
--- /dev/null
+++ b/addressbook/backend/ebook/Makefile.am
@@ -0,0 +1,52 @@
+corbadir = $(sysconfdir)/CORBA/servers
+
+CORBA_SOURCE = \
+ addressbook.h \
+ addressbook-common.c \
+ addressbook-stubs.c \
+ addressbook-skels.c
+
+idls = \
+ ../idl/addressbook.idl
+
+idl_flags = `$(GNOME_CONFIG) --cflags idl`
+
+$(CORBA_SOURCE): $(idls)
+ $(ORBIT_IDL) ../idl/addressbook.idl $(idl_flags)
+
+INCLUDES = \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DG_LOG_DOMAIN=\"EBook\" \
+ -I$(srcdir) -I$(top_srcdir) \
+ -I. \
+ -I.. \
+ -I$(top_builddir) \
+ -I$(includedir) \
+ $(GNOME_INCLUDEDIR)
+
+gnome_libs = \
+ $(GNOME_LIBDIR) \
+ $(GNOMEUI_LIBS) \
+ $(GNOMEGNORBA_LIBS) \
+ $(INTLLIBS)
+
+ebook_libs = \
+ libebook.la \
+ $(gnome_libs)
+
+lib_LTLIBRARIES = libebook.la
+
+libebook_la_SOURCES = \
+ $(CORBA_SOURCE) \
+ e-book-listener.c \
+ e-book.c
+
+libebookincludedir = $(includedir)/backend
+
+libebookinclude_HEADERS = \
+ e-book.h \
+ e-book-listener.h \
+ e-card.h
+
+BUILT_SOURCES = $(CORBA_SOURCE)
+CLEANFILES += $(BUILT_SOURCES)