aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
index c28b911271..ed05a02fcd 100644
--- a/addressbook/backend/ebook/Makefile.am
+++ b/addressbook/backend/ebook/Makefile.am
@@ -50,6 +50,15 @@ libebookinclude_HEADERS = \
e-card-types.h \
e-card.h
+
+#
+# make a static library for use by addressbook's conduit's shared library
+#
+noinst_LTLIBRARIES = libebook-static.la
+libebook_static_la_SOURCES = $(libebook_la_SOURCES)
+libebook_static_la_LDFLAGS = --all-static
+
+
test_client_SOURCES = \
test-client.c