aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/Makefile.am')
-rw-r--r--addressbook/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/addressbook/Makefile.am b/addressbook/Makefile.am
index d307057f02..4fde08a4a9 100644
--- a/addressbook/Makefile.am
+++ b/addressbook/Makefile.am
@@ -5,5 +5,19 @@ endif
SUBDIRS = \
util printing gui importers tools $(CONDUIT_SUBDIR)
-EXTRA_DIST = \
- ChangeLog.pre-1-4
+error_DATA = addressbook-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
+errordir = $(privdatadir)/errors
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
+
+EXTRA_DIST = \
+ ChangeLog.pre-1-4 \
+ $(error_DATA)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
+BUILT_SOURCES = $(error_i18n)
+
+CLEANFILES = $(BUILT_SOURCES)