aboutsummaryrefslogtreecommitdiffstats
path: root/a11y/calendar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'a11y/calendar/Makefile.am')
-rw-r--r--a11y/calendar/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/a11y/calendar/Makefile.am b/a11y/calendar/Makefile.am
index 849e152135..2c3a26f2ba 100644
--- a/a11y/calendar/Makefile.am
+++ b/a11y/calendar/Makefile.am
@@ -1,4 +1,46 @@
+# Calendar IDL files
+
+CALENDAR_IDLS = $(top_srcdir)/calendar/idl/evolution-calendar.idl
+SHELL_IDLS = \
+ $(top_srcdir)/shell/Evolution-Activity.idl \
+ $(top_srcdir)/shell/Evolution-ConfigControl.idl \
+ $(top_srcdir)/shell/Evolution-Offline.idl \
+ $(top_srcdir)/shell/Evolution-Session.idl \
+ $(top_srcdir)/shell/Evolution-Shell.idl \
+ $(top_srcdir)/shell/Evolution-ShellComponent.idl \
+ $(top_srcdir)/shell/Evolution-ShellComponentDnd.idl \
+ $(top_srcdir)/shell/Evolution-ShellView.idl \
+ $(top_srcdir)/shell/Evolution-Shortcuts.idl \
+ $(top_srcdir)/shell/Evolution-Storage.idl \
+ $(top_srcdir)/shell/Evolution-StorageSetView.idl \
+ $(top_srcdir)/shell/Evolution-Wizard.idl \
+ $(top_srcdir)/shell/Evolution-common.idl \
+ $(top_srcdir)/shell/Evolution.idl
+
+CALENDAR_IDL_GENERATED_H = evolution-calendar.h
+CALENDAR_IDL_GENERATED_C = \
+ evolution-calendar-common.c \
+ evolution-calendar-skels.c \
+ evolution-calendar-stubs.c
+SHELL_IDL_GENERATED_H = Evolution.h
+SHELL_IDL_GENERATED_C = \
+ Evolution-common.c \
+ Evolution-skels.c \
+ Evolution-stubs.c
+
+$(CALENDAR_IDL_GENERATED_H): $(CALENDAR_IDLS)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) \
+ $(top_srcdir)/calendar/idl/evolution-calendar.idl
+
+$(SHELL_IDL_GENERATED_H): $(SHELL_IDLS)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) \
+ $(top_srcdir)/shell/Evolution.idl
+
+IDL_GENERATED = $(SHELL_IDL_GENERATED_H) $(CALENDAR_IDL_GENERATED_H)
+BUILT_SOURCES = $(IDL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES) $(CALENDAR_IDL_GENERATED_C) $(SHELL_IDL_GENERATED_C)
+
noinst_LTLIBRARIES = libevolution-calendar-a11y.la
INCLUDES = \
@@ -22,6 +64,8 @@ INCLUDES = \
$(EVOLUTION_CALENDAR_CFLAGS)
libevolution_calendar_a11y_la_SOURCES = \
+ $(CALENDAR_IDL_GENERATED_H) \
+ $(SHELL_IDL_GENERATED_H) \
ea-calendar.c \
ea-calendar.h \
ea-calendar-helpers.c \