aboutsummaryrefslogtreecommitdiffstats
path: root/a11y/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'a11y/Makefile.am')
-rw-r--r--a11y/Makefile.am35
1 files changed, 2 insertions, 33 deletions
diff --git a/a11y/Makefile.am b/a11y/Makefile.am
index 0a9a210cba..796eeba234 100644
--- a/a11y/Makefile.am
+++ b/a11y/Makefile.am
@@ -1,36 +1,5 @@
-# Calendar IDL files
-
-CALENDAR_IDLS = $(top_srcdir)/calendar/idl/evolution-calendar.idl
-CALENDAR_IDL_GENERATED_H = evolution-calendar.h
+SUBDIRS = calendar widgets
-$(CALENDAR_IDL_GENERATED_H): $(CALENDAR_IDLS)
- $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) \
- $(top_srcdir)/calendar/idl/evolution-calendar.idl
-SUBDIRS = calendar
-
-INCLUDES = \
- -DPREFIX=\"$(prefix)\" \
- -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DDATADIR=\"$(datadir)\" \
- -DLIBDIR=\"$(libdir)\" \
- -DG_LOG_DOMAIN=\"evolution-a11y\" \
- -I$(top_srcdir) \
- -DG_DISABLE_DEPRECATED \
- -DLIBGNOME_DISABLE_DEPRECATED \
- $(EVOLUTION_CALENDAR_CFLAGS) \
- $(A11Y_CFLAGS)
-
-privlib_LTLIBRARIES = libevolution-a11y.la
-
-libevolution_a11y_la_SOURCES = \
- $(CALENDAR_IDL_GENERATED_H) \
- ea-factory.h
-
-
-BUILT_SOURCES = $(CALENDAR_IDL_GENERATED_H)
-
-libevolution_a11y_la_LIBADD = \
- $(A11Y_LIBS) \
- $(top_builddir)/a11y/calendar/libevolution-calendar-a11y.la
+EXTRA_DIST = ea-factory.h