aboutsummaryrefslogtreecommitdiffstats
path: root/a11y/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'a11y/Makefile.am')
-rw-r--r--a11y/Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/a11y/Makefile.am b/a11y/Makefile.am
index 96a9014b70..960287aa70 100644
--- a/a11y/Makefile.am
+++ b/a11y/Makefile.am
@@ -1,12 +1,19 @@
+# Somewhat odd looking to have "." in SUBDIRS, but apparently it works?
SUBDIRS = e-text e-table . calendar widgets addressbook
+if OS_WIN32
+WIN32_BOOTSTRAP_LIBS = \
+ $(top_builddir)/win32/libemiscwidgets.la \
+ $(top_builddir)/win32/libetable.la \
+ $(top_builddir)/win32/libetext.la
+endif
+
# for debug
#A11Y_CFLAGS += -pedantic -ansi -DACC_DEBUG -Werror
privlib_LTLIBRARIES = libevolution-a11y.la
INCLUDES = \
- -I$(top_srcdir)/a11y \
$(A11Y_CFLAGS)
libevolution_a11y_la_SOURCES = \
@@ -21,8 +28,11 @@ libevolution_a11yinclude_HEADERS = \
gal-a11y-util.h \
gal-a11y-factory.h
-libevolution_a11y_la_LIBADD = \
- e-text/libgal-a11y-etext.la \
- e-table/libgal-a11y-etable.la \
- $(EXTRA_GNOME_LIBS) \
- $(REGEX_LIBS)
+libevolution_a11y_la_LDFLAGS = $(NO_UNDEFINED)
+
+libevolution_a11y_la_LIBADD = \
+ $(WIN32_BOOTSTRAP_LIBS) \
+ e-text/libgal-a11y-etext.la \
+ e-table/libgal-a11y-etable.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EXTRA_GNOME_LIBS)