aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a9c2000693..c66a8aaff6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,3 +72,20 @@ SUBDIRS = \
< $(srcdir)/$< > $@.tmp \
&& mv $@.tmp $@
+# CDE Stuff
+
+if HAVE_DTAPPINTEGRATE
+
+# This installs Evolution into the Application Manager on CDE
+dtappintegrate:
+ ( cd data && make dtappintegrate )
+
+# ...And this uninstalls it
+dtappunintegrate:
+ ( cd data ; make dtappunintegrate )
+
+# Install/uninstall for CDE
+cde-install: install dtappintegrate
+cde-uninstall: dtappunintegrate uninstall
+
+endif