aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am50
1 files changed, 49 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 42ffacc264..0aa8f77438 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1,49 @@
-SUBDIRS = C
+changelogs = \
+ ChangeLog
+
+appicondir = $(datadir)/pixmaps
+appicon_DATA = evolution.png
+
+applicationdir = $(datadir)/gnome/apps/Applications
+application_DATA = evolution.desktop
+
+EXTRA_DIST = \
+ AUTHORS \
+ $(changelogs) \
+ README \
+ HACKING \
+ MAINTAINERS \
+ NEWS \
+ evolution.spec.in \
+ $(appicon_DATA) \
+ $(application_DATA)
+
+
+SUBDIRS = \
+ intl \
+ macros \
+ data \
+ e-util \
+ widgets \
+ shell \
+ libibex \
+ camel \
+ filter \
+ composer \
+ mail \
+ libical \
+ libversit \
+ addressbook \
+ calendar \
+ wombat \
+ art \
+ default_user \
+ tools \
+ po \
+ doc
+
+
+dist-hook: evolution.spec
+ cp evolution.spec $(distdir)
+
+