aboutsummaryrefslogtreecommitdiffstats
path: root/wombat/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-11-16 06:20:41 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-11-16 06:20:41 +0800
commitb39725006cebc16f96cc2d43885697d464365183 (patch)
tree2a799d49001e661858292ddbdbde34cea77c7c29 /wombat/Makefile.am
parenta47eb7a9a182c9d124fa8c98c852b0bdcfa245f4 (diff)
downloadgsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.tar
gsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.tar.gz
gsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.tar.bz2
gsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.tar.lz
gsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.tar.xz
gsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.tar.zst
gsoc2013-evolution-b39725006cebc16f96cc2d43885697d464365183.zip
Added rule to create GNOME_Evolution_Wombat.server.in from
* Makefile.am: Added rule to create GNOME_Evolution_Wombat.server.in from GNOME_Evolution_Wombat.server.in.in, substituting @LIBEXECDIR@. Also install wombat in $libexecdir instead of $bindir. * GNOME_Evolution_WombatNOLDAP.server.in.in: Renamed from GNOME_Evolution_WombatNOLDAP.server.in. Changed the location from "wombat" to "@LIBEXECDIR@/wombat". * GNOME_Evolution_WombatLDAP.server.in.in: Renamed from GNOME_Evolution_WombatLDAP.server.in. Changed the location from "wombat" to "@LIBEXECDIR@/wombat". svn path=/trunk/; revision=18795
Diffstat (limited to 'wombat/Makefile.am')
-rw-r--r--wombat/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/wombat/Makefile.am b/wombat/Makefile.am
index a360e76e85..61e9c91b6d 100644
--- a/wombat/Makefile.am
+++ b/wombat/Makefile.am
@@ -17,7 +17,7 @@ INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
$(WOMBAT_CFLAGS)
-bin_PROGRAMS = \
+libexec_PROGRAMS = \
wombat
wombat_SOURCES = \
@@ -50,16 +50,20 @@ wombat_LDADD = \
serversdir = $(libdir)/bonobo/servers
if ENABLE_LDAP
-SERVER_IN_FILE=GNOME_Evolution_WombatLDAP.server.in
+SERVER_IN_FILE=GNOME_Evolution_WombatLDAP.server.in.in
else
-SERVER_IN_FILE=GNOME_Evolution_WombatNOLDAP.server.in
+SERVER_IN_FILE=GNOME_Evolution_WombatNOLDAP.server.in.in
endif
-GNOME_Evolution_Wombat.server.in: $(SERVER_IN_FILE)
+GNOME_Evolution_Wombat.server.in.in: $(SERVER_IN_FILE)
cp $< $@
-server_in_files = GNOME_Evolution_Wombat.server.in
-servers_DATA = $(server_in_files:.server.in=.server)
+server_in_files = GNOME_Evolution_Wombat.server.in.in
+
+serverdir = $(libdir)/bonobo/servers
+server_DATA = $(server_in_files:.server.in.in=.server)
+$(server_in_files:.server.in.in=.server.in): $(server_in_files)
+ sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
@@ -67,7 +71,7 @@ idldir = $(datadir)/idl
idl_DATA = Evolution-Wombat.idl
-EXTRA_DIST = $(servers_DATA) $(server_in_files) $(idl_DATA) \
+EXTRA_DIST = $(server_DATA) $(server_in_files) $(idl_DATA) \
GNOME_Evolution_WombatLDAP.server.in GNOME_Evolution_WombatNOLDAP.server.in
if ENABLE_PURIFY