aboutsummaryrefslogtreecommitdiffstats
path: root/wombat/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2001-10-03 06:37:58 +0800
committerChris Toshok <toshok@src.gnome.org>2001-10-03 06:37:58 +0800
commit3cfa7824a8c01c979621965131319a8073f064ed (patch)
treef0122526440c03314853eae56835a9f6d1ff9513 /wombat/Makefile.am
parent1747072ed0c4fee3bbfa2e0d96035cd35b201d70 (diff)
downloadgsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.tar
gsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.tar.gz
gsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.tar.bz2
gsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.tar.lz
gsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.tar.xz
gsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.tar.zst
gsoc2013-evolution-3cfa7824a8c01c979621965131319a8073f064ed.zip
add addressbook:supported_protocols containing just the file protocol.
2001-10-02 Chris Toshok <toshok@ximian.com> * GNOME_Evolution_WombatNOLDAP.oaf.in: add addressbook:supported_protocols containing just the file protocol. * GNOME_Evolution_WombatLDAP.oaf.in: add addressbook:supported_protocols containing both ldap and file. * Makefile.am (OAF_IN_FILE): we have to possible files now, since the addressbook looks up factories by corba interface and the protocols supported by the factory (as listed in the .oaf file.) * .cvsignore: ignore GNOME_Evolution_Wombat.oaf.in, since it's generated now. svn path=/trunk/; revision=13356
Diffstat (limited to 'wombat/Makefile.am')
-rw-r--r--wombat/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/wombat/Makefile.am b/wombat/Makefile.am
index be09560e64..648d199d30 100644
--- a/wombat/Makefile.am
+++ b/wombat/Makefile.am
@@ -43,13 +43,23 @@ wombat_LDADD = \
oafdir = $(datadir)/oaf
+if ENABLE_LDAP
+OAF_IN_FILE=GNOME_Evolution_WombatLDAP.oaf.in
+else
+OAF_IN_FILE=GNOME_Evolution_WombatNOLDAP.oaf.in
+endif
+
+GNOME_Evolution_Wombat.oaf.in: $(OAF_IN_FILE)
+ cp $< $@
+
oaf_in_files = GNOME_Evolution_Wombat.oaf.in
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
@XML_I18N_MERGE_OAF_RULE@
-EXTRA_DIST = $(oaf_DATA) $(oaf_in_files) wombat.idl
+EXTRA_DIST = $(oaf_DATA) $(oaf_in_files) wombat.idl \
+ GNOME_Evolution_WombatLDAP.oaf.in GNOME_Evolution_WombatNOLDAP.oaf.in
if ENABLE_PURIFY
PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@